Answers to Application Activities in Chapter 10

10. 1.2 Application Activity in Understanding Interaction

1. When feedback is given the use of explicit or implicit instruction makes no difference, but when feedback is absent, participants perform much better with explicit instruction.

2. When students received traditional laboratory training for pronunciation they were able to produce segments and intonation with the same amount of accuracy, but when a special mimicry technique was used, students did much worse accurately producing segments.

3. Study abroad students with high motivation always do better than those with low motivation and this seems to hold true no matter whether language aptitude scores are high or low (these lines are not quite parallel, but almost). However, length of immersion makes a big difference; those with high motivation can do well even with a short amount of immersion but once students have been immersed for a year even participants with low motivation do much better.

4. For children the context, whether study at home or study abroad, makes little difference to gain scores on a language proficiency test—gains are approximately equal. However, for adults, the gains for the study abroad program are much higher than the gains for study at home.

5. For NS and for heritage speakers the scores for forming the two different types of plurals in Arabic are approximately the same. However, for L2 learners of Arabic, broken plurals appear to be much more difficult, and the L2 learners score lower on this language feature, than the sound plurals.
10.1.5 Application Activity: Identifying Independent Variables and Levels

1 Pandey (2000)
This is a one-way ANOVA.

   1  TOEFL score with 4 levels (1 for each of the classes)

2 Takimoto (2006)
This is a two-way ANOVA.*

   1  Instruction with 3 levels (SI, SF, and control)
   2  Time with 2 levels (pretest and posttest)

*Actually, because one of the variables was time, Takimoto would have obtained more statistical power by using a repeated measures ANOVA (see Chapter 11 of the book for more information).

3 Smith, McGregor and Demille (2006)
This is a two-way ANOVA.

   1  Age with two levels (24 months or 30 months)
   2  Vocabulary size with two levels (average or advanced)

4 Sanz and Morgan-Short (2004)
This is a two-way ANOVA.

   1  Explanation with two levels
   2  Feedback with two levels
5 Muñoz & Llanes (2014)
This is a two-way ANOVA.

1. Age with two levels (child or adult)
2. Place of study with two levels (abroad or at home)

6 Dahl & Ludvigsen (2014)
This is a two-way ANOVA.

1. Age with two levels (child or adult)
2. Language proficiency with two levels (NS or SL learner of English)

7 Albirini & Banmamoun (2014)
This is a two-way ANOVA.

1. Type of language learner with three levels (NS, heritage learner, L2 learner)
2. Two kinds of plural morphology with two levels (sound plurals or broken plurals)

8 Letts, Edwards, Sinka, Schaefer & Gibbons (2013)
If both maternal level of education and the child’s age are examined, this is a two-way ANOVA.
If the results from all age bands are lumped together and only the question of whether maternal education plays a role in results, then this is a one-way ANOVA.

1. Maternal levels of education with two levels (finished school at 16 years of age or have more school than 16 years)
2. Age of child with 11 levels (ages divided into 6-month bands)
10.5.6 Application Activity with Factorial ANOVA (Both SPSS and R Answers Given)
1 Obarow (2004)

Use Obarow.Story2.sav file. Import into R as `obarow2`.

**a. Getting the File into Shape**

**SPSS Instructions:**

*Calculate a gainscore:* TRANSFORM > COMPUTE VARIABLE. Create a “Numeric Expression” that says “POSTTEST2 – PRETEST2.” In the box labeled “Target Variable,” give it a new name (GAINSCORET2). While here, if you want to delete cases where individuals scored above 17 on the pretest, go to the button at the bottom that says IF . . . . (optional case selection condition). Push the button and in the new dialogue box, change the radio button to “Include if case satisfies condition” then enter the variable PRETEST2 into the box. We want to include the variable if the pretest score is 17 or below, so add the operator “<=" and the number “17” to now have an equation that reads “PRETEST2<=17.” Press Continue, and then OK. The cases where the pretest is over 17 will now have a dot in the column and will not be included in the calculation. If you need to, go to the “Variable View” tab (at bottom) and change decimals for this variable to 0 (I don’t like looking at the decimals when I don’t need them).

*Recode the trtmnt2 variable into two columns:* Go to TRANSFORM > RECODE INTO DIFFERENT VARIABLES. Put TRTMNT2 into the box labeled “Input variable -> Output variable,” and under Output variable, give it a new name. Let’s call it MUSICT2. Click the CHANGE button. Now click the “Old and New Values” button. Use these values, with the first number I give in the left-hand column under “Old Value” heading, radio button “Value,” and the second number in the right-hand column under “New Value” heading, radio button “Value”: 1 = 1, 2 = 1, 3 = 2, 4 = 2 (after
each entry, push the “Add” button). After these 4 directives are entered, click CONTINUE then OK. When you see the new column called MUSIC{T2} in your file, go to the “Variable View” tab at the bottom of the window and then to the column called “Values” for MUSIC{T2} to insert values so you remember that 1 = no music and 2 = music.

To get the PICTURES{T2} column, open TRANSFORM > RECODE INTO DIFFERENT VARIABLES. Move the previous equation out of the “Numeric variable -> Output variable” box, then move TRTMNT2 back in. Repeat the steps in the previous paragraph but now call the output variable PICTURES{T2} and use these values: 1 = 1, 2 = 2, 3 = 1, 4 = 2 (you’ll have the previous coding there, so just click on and remove the ones that are different this time). When you get this column, again go to the values column and recode so that 1 = no pictures and 2 = pictures.

Notice that by using the choice RECODE INTO DIFFERENT VARIABLES instead of RECODE INTO SAME VARIABLES I keep the original TRTMNT2 column. Technically, I don’t need it, but I feel safer having it there and not erasing it. If you use the RECODE INTO SAME VARIABLES for the first variable of MUSIC{T2}, it won’t be available for the second time you need to use it, so this seems like a safe approach. However, when making the second variable, you could use RECODE INTO SAME VARIABLES and thus get rid of the original TRTMNT2 column.

**R Instructions:**

*Delete cases where individuals scored above 17 on the pretest:*

```r
new.obarow2 <- subset(obarow2, subset=pretest2<18)
```
obarow2<-new.obarow2 #rename file so it's shorter

*Calculate a gainscore:*

obarow2$gainscore <- with(obarow2, postest2- pretest2)

*Recode the trtmnt2 variable into two columns:*

levels(obarow2$trtmnt2)

[1] "no music no pics" "no music yes pics" "yes music no pics"

[4] "yes music yes pics"

library(plyr) #if needed, install.packages("plyr")

obarow2$musict2<-revalue(obarow2$trtmnt2, c("no music no pics"="no music",
"no music yes pics"="no music", "yes music no pics"="music", "yes music yes
pics"="music"))

obarow2$picturest2<-revalue(obarow2$trtmnt2, c("no music no pics"="no pics",
"no music yes pics"="yes pics", "yes music no pics"="no pics", "yes music yes
pics"="yes pics"))

b. **Examine the Data Visually and Numerically**

**SPSS Instructions:**

For boxplots, histograms and numerical values from one command, choose **ANALYZE > DESCRIPTIVE STATISTICS > EXPLORE.** Put the one dependent variable of GAINSCORET2 in the “Dependent List” box. Put the three independent variables of GENDER, MUSICT2 and PICTURES T2 in the “Factor List.” Open the “Plots” button and tick off “Stem-and-leaf” (we don’t really look at these) and tick on “Histogram.” Press Continue and then OK. This configuration of the Explore command will produce numerical descriptive stats including skewness and kurtosis.
numbers, histograms and boxplots for the dependent variable split by each of the 3 independent variables at one time.

**R Instructions:**

The combination boxplot and means plot is a nice way to visually examine the data:

```r
library(HH)
attach(obarow2)
interaction2wt(gainscore~gender*picturest2*musict2, par.strip.text=list(cex=.6),
main.in="Effects of Gender, Music & Pictures on Vocabulary Learning", box.ratio=.3,
rot=c(90,90),
factor.expressions=
c(musict2=expression("Music"),
picturest2=expression("Pictures"),
gender=expression("Gender")),
responselab.expression="Gain\nscore")
```

Actually, this command produces a graphic that isn’t complete. I check, and indeed I have some NAs in my data, so I need to get rid of those lines. I’ll create a new file with no NAs:

```r
new.obarow2<-na.omit(obarow2)
```
Now run the plot above with `new.obarow2` and it works. Wait! I attached the `obarow2` dataset, so what I need to do is detach it and attach the new one, then run the exact same code:

```r
detach(obarow2)
attach(new.obarow2)
```

To see numerical results for skewness and kurtosis, use R Commander: STATISTICS > SUMMARIES > NUMERICAL SUMMARIES. Choose the `gainscore` and open the “Summarize by groups” button and pick `gender` first. Go to the “Statistics” tab and tick off everything then tick on Skewness and Kurtosis. Press “Apply,” then go back to the “Data” tab and open the “Summarize by: gender” button and pick `musict2` next. Press “Apply,” then open the “Summarize by: musict2” button and pick `picturest2` last, and this time hit OK.

The R code is:

```r
numSummary(obarow2[,"gainscore"], groups=obarow2$gender,
statistics=c("skewness", "kurtosis"), quantiles=c(0,.25,.5,.75,1), type="2")
```

To look at histograms, in R Commander choose GRAPHS > HISTOGRAM. Choose `gainscore` as the “Variable,” then open the “Plot by groups” button and choose `gender` first. Press “Apply,” then go back to the “Data” tab and open the “Summarize by: gender” button and pick `musict2` next. Press “Apply,” then open the “Summarize by: musict2” button and pick `picturest2` last, and this time hit OK.

The R code for the first one is:
with(obarow2, Hist(gainscore, groups=gender, scale="frequency", breaks="Sturges", col="darkgray"))

Results:

For normality, there appear to be outliers in the gainscore when divided using Music and also Pictures, so the data are not exactly normally distributed for these variables. The boxplots for the gainscore divided by Gender are identical, and have no outliers and looks fairly normally distributed. Numerically, skewness values are not over 1 and kurtosis values are also low. Variances for the boxes are a little different when divided using Music and also Pictures, but are the same for Gender, so I would say variances are not homoscedastic for the gainscore when divided by Music and Pictures.

c. Get descriptive statistics

For both SPSS and R you can get descriptive statistics when you run the factorial ANOVA, but I think the descriptives for SPSS are not in as compact a form as I would like, so I will describe a way to get the data in a different way that I think makes it easier to collect for your own table. For R the data is fairly compact (although you would want to put it into a nicer-looking table) but you may want to split the data up into different ways (by fewer variables), so I will show how to do this here. We will split the dataset by three independent variables: Music, Pictures, Gender. Each of these has 2 levels, so we will get 8 different configurations of the data ($2 \times 2 \times 2 = 8$).

SPSS Instructions:

The SPSS menu choice \texttt{DATA > SPLIT FILE} makes it easy to divide up your data in any way that you need it. To get the data split by all of the variables, go to the Split File dialogue box and tick
the “Organize output by groups” button. Then in the box labeled “Groups Based On,” put in all of the variables you want. The order you put the variables in will be the order they are split in. Press OK. Next go to Analyze > Descriptive Statistics > Descriptives. Put the GAINSCORET2 in the “Variable(s)” box. If you like (and I did because I wanted my output to be as simple as possible, you can open the “Options” button and tick off “Minimum” and “Maximum.” Then press OK. You'll now see the N, mean, and SD for each of the 8 categories.

R Instructions:

We can get the descriptives for the 8 categories just by running the factorial ANOVA in R Commander: Statistics > Means > Multi-way ANOVA (make sure obarow2 is the active dataset). Choose the “Factors” of gender, musict2 and picturest2. Choose the “Response Variable” of gainscore. Press OK.

The code for this is:

```r
with(obarow2, (tapply(gainscore, list(gender, musict2, picturest2), mean, na.rm=TRUE))) # means
with(obarow2, (tapply(gainscore, list(gender, musict2, picturest2), sd, na.rm=TRUE))) # std. deviations
with(obarow2, (tapply(gainscore, list(gender, musict2, picturest2), function(x) sum(!is.na(x)))))) # counts
```
If you later want to get summary data for different configurations of the dataset, such as a split by only two variables, just put only the variables you want to split by in the `list()` portion of the code.

**Results:**

SPSS and R return the same descriptives. Notice that these are the descriptives split into their smallest parts. For example, you may want to compare only males and females across all other categories.

<table>
<thead>
<tr>
<th></th>
<th>Mean</th>
<th>SD</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td>No pictures</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No music</td>
<td>1.33</td>
<td>1.87</td>
<td>9</td>
</tr>
<tr>
<td>Male</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No Music</td>
<td>0.86</td>
<td>1.57</td>
<td>7</td>
</tr>
<tr>
<td>Female</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Music</td>
<td>1.90</td>
<td>1.10</td>
<td>10</td>
</tr>
<tr>
<td>Male</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Music</td>
<td>1.40</td>
<td>1.42</td>
<td>5</td>
</tr>
<tr>
<td>Female</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pictures</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No music</td>
<td>1.00</td>
<td>2.39</td>
<td>8</td>
</tr>
<tr>
<td>Male</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No music</td>
<td>1.17</td>
<td>2.04</td>
<td>6</td>
</tr>
<tr>
<td>Female</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Music</td>
<td>1.00</td>
<td>1.41</td>
<td>4</td>
</tr>
<tr>
<td>Male</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Music</td>
<td>1.00</td>
<td>1.32</td>
<td>9</td>
</tr>
<tr>
<td>Female</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Notice that the descriptives are the same whatever order the three IVs are found in, so that [No pictures: No Music: Male] is the same as [Male: No Pictures: No Music] or [No Music: Male: No Pictures].
**d. Run the Factorial ANOVA with Traditional Output**

**SPSS Instructions:**

To perform the factorial three-way ANOVA (2×2×2 in this case), go to **ANALYZE > GENERAL LINEAR MODEL > UNIVARIATE.** Enter `gainscoreT2` in the Dependent box, and `GENDER`, `MUSIC2` and `PICTURE2` in the Fixed effects box. Click the **MODEL** button and change to Type II sums of squares. Press Continue. Open the **PLOTS** button. Try a couple of different plot configurations, putting the variables in the boxes in different order, so that in the “Plots” box, after you press the “Add” button, you’ll see code such as `gender*music2*picture2` and `music2*gender*picture2`. Press Continue. Because none of the variables have more than two levels, there is no need to open the “Post Hoc” button, which will only run post-hoc tests for the main effects. Open the **SAVE** button and tick “Cook’s distance” under “Diagnostics,” and “Unstandardized” under “Residuals.” Press **CONTINUE.** Open the **OPTIONS** button and under “Display,” tick “Descriptive Statistics,” “Homogeneity tests,” “Spread vs. level plot,” and “Residual plot.” Press **CONTINUE** and **OK** to run the analysis.

**R Instructions:**

To perform the factorial three-way ANOVA (2×2×2 in this case), in R Commander, make sure the `obarow2` dataset is active and choose **STATISTICS > MEANS > MULTI-WAY ANOVA.** In the “Factors” box choose `gender`, `music2` and `picture2`. For the “Response Variable” box, choose `gainscore`. Press OK. Note that because the model is called by the generic automatic label “AnovaModel.1,” and you probably have some of those still rattling around, you may get a warning that asks you if you want to overwrite the previous model. Change the model name if you don’t want to overwrite previous models, or just click OK if you are done with all previous models. This will give the F statistics and p-values for all seven terms in the regression equation.
as well as means, sds and N for the 8 different configurations of the data (2 choices for pictures × 2 choices for music × 2 genders = 8).

The last line of the ANOVA table shows that the Residuals = 143.8, which is a large number relative to the sums of squares (none of which are larger than 2), which means that the model does not account for much of the variation in the data. To get the R² value, call for the summary of the model:

```r
summary(AnovaModel.1)
```

To examine regression assumptions, just plot the ANOVA model that was created (it will produce 4 plots, so if you want, run the first line here to put all 4 plots on one page):

```r
par(mfrow = c(2, 2), oma = c(0, 0, 2, 0))
plot(AnovaModel.1)
par(mfrow = c(1, 1))  # to return to normal
```

**Results:**

The seven terms in the regression equation (values are equal in SPSS or R):

<table>
<thead>
<tr>
<th>Term</th>
<th>F₁,₅₀</th>
<th>p</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gender</td>
<td>F₁,₅₀ = .23, p = .64</td>
<td></td>
</tr>
<tr>
<td>MusicT2</td>
<td>F₁,₅₀ = .34, p = .57</td>
<td></td>
</tr>
<tr>
<td>PicturesT2</td>
<td>F₁,₅₀ = .47, p = .50</td>
<td></td>
</tr>
<tr>
<td>Gender*MusicT2</td>
<td>F₁,₅₀ = .01, p = .92</td>
<td></td>
</tr>
<tr>
<td>Gender*PicturesT2</td>
<td>F₁,₅₀ = .39, p = .54</td>
<td></td>
</tr>
</tbody>
</table>
None of the terms are statistical. In an “old statistics” approach to a factorial ANOVA, you would report these numbers as well as the descriptive statistics and simply say that none of the interactions were statistical, and none of the main effects were statistical either, so you would conclude that none of the independent variables of gender, music or pictures had any effect on the gain scores for the second treatment. Additionally, the $R^2$ value shows that this equation explains very little of the variance in the model.

**Assumptions:**

Levene’s test for homogeneity of variances has $p = .69$, which indicates no problems with homogeneity of variances. The spread vs. level plot may show some restrictions to the bottom left-hand triangle (that’s the only place the data are). The residual plot (studentized residual vs. predicted value of standardized residuals) (what R calls the Residuals vs. Fitted plot) looks randomly distributed except there is a lack of data around the fitted value of 1.6. The Normal Q-Q plot shows some movement away from the straight line on the top end of the distribution, meaning there may be some problems with the assumption of normality. There don’t appear to be problems with residual outliers according to Cook’s distance.
e. **Run the Factorial ANOVA to get CIs on the Comparisons**

**First Step: Three-way Interactions:**

First we will look at CIs for three-way interactions. Ultimately, we could have 24 different configurations of the data, because for the first slot we have 6 choices for terms (male, female, music, no music, pictures, no pictures); once we pick one of those we have 4 choices for terms (say we picked male, then our choices are music, no music, pictures or no pictures), and last only 1 choice, so there are $6 \times 4 \times 1 = 24$ combinations. However, the combination [Male: No Music: Pictures-no Pictures] is the same as the combination [No Music: Male: Pictures-no Pictures] so we really only need 12 comparisons for the three-way interactions. To get confidence intervals for these, we need to first look at pairwise comparisons among two variables only.

**SPSS Instructions:**

I am assuming here that you have already run your analysis one time (for the traditional type of results). Go back to the **ANALYZE > GENERAL LINEAR MODEL > UNIVARIATE** choice. Press the “Reset” button at the bottom to reset all of the buttons. Enter **GAINSCORET2** in the Dependent box, and **GENDER**, **MUSICT2** and **PICTURET2** in the Fixed effects box. Click the **MODEL** button and change to Type II sums of squares. Press Continue. Open the “Options” button and in the box under “Factor(s) and Factor Interactions” move the largest of your ANOVA parts that involve interactions over to the right to the “Display means for” box (so for this data set you will move the gender*MusicT2*PicturesT2 term over).

Press the “Paste” button at the bottom of the dialogue box, which brings up the Syntax Editor. Find the line that says **EMMEANS.** We are looking for the line that says:
/EMMEANS=TABLES(gender*musict2*picturest2)

Copy this line, then paste it and add the command COMPARE(gender) to it, right after the original line, like this:

/EMMEANS=TABLES(gender*MusicT2*PicturesT2)COMPARE(gender)

This will give us a 4 comparisons that have confidence intervals:

No music: No pictures: male-female
No music: Pictures: male-female
Music: No pictures: male-female
Music: Pictures: male-female

Since the variables here only have two variables, and since we need 12 comparisons, that means we need to run the syntax 3 times, with each variable at the end.

So paste in these lines as well, underneath the previous one:

/EMMEANS=TABLES(gender*MusicT2*PicturesT2)COMPARE(MusicT2)
/EMMEANS=TABLES(gender*MusicT2*PicturesT2)COMPARE(PicturesT2)

The line with COMPARE(MusicT2) will give the 4 comparisons:

Male: No pictures: No music-music
Male: Pictures: No music-music
Female: No pictures: no music-music
Female: Pictures: No music-music

The line with COMPARE(PicturesT2) will give the 4 comparisons:
Male: No music: No pictures:pictures
Male: Music: No pictures-pictures
Female: No music: No pictures:pictures
Female: Music: No pictures-pictures

Once all of the syntax is ready, choose RUN > ALL. By the way, should you have to run this syntax more than once you will see that it accumulates so you get several runs of the UNIANOVA. You can always highlight the run that you are interested in and then run just that part (RUN > SELECTION).

**R Instructions:**

To get our 12 comparison, we’ll need to split the file. Which variable to split by first? Let’s just use the same one as I used in the chapter, and split first by Pictures. Notice that I will use the obarow2 file, not the new.obarow2 file, since the commands I will use on the data do not have problems with NAs.

```r
attach(obarow2) # makes it easier to type names
names(obarow2) # find out the names of the dataset
levels(picturest2) # find out the exact level names
```
[1] “no pictures” “pictures”

```r
obarow2 <- subset(obarow2, subset=picturest2 == "no pictures")
O2.pics <- subset(obarow2, subset=picturest2 == "pictures")
str(obarow2) # I do this to look at the structure of my new file and make sure everything’s OK
str(O2.pics)
detach(obarow2)
```

Now run the pairwise comparisons using the `multcomp` package:

```r
library(multcomp)

# No Pictures, music, gender
Tukey = contrMat(table(obarow2$gender), "Tukey")
K1 = cbind(Tukey, matrix(0, nrow = nrow(Tukey), ncol = ncol(Tukey)))
rownames(K1) = paste(levels(obarow2$musict2)[1], rownames(K1), sep = ":")
K2 = cbind(matrix(0, nrow = nrow(Tukey), ncol = ncol(Tukey)), Tukey)
rownames(K2) = paste(levels(obarow2$musict2)[2], rownames(K2), sep = ":")
K = rbind(K1, K2)
colnames(K) = c(colnames(Tukey), colnames(Tukey))
obarow2$gm = with(obarow2, interaction(gender, musict2))

cell = lm(gainscore ~ gm - 1, data = obarow2)
summary(glht(cell, linfct = K))
confint(glht(cell, linfct = K))
```
This code will give the 95% CIs for the comparisons of:

No pictures: No Music: Female-Male

No pictures: Music: Female-Male

Change the code to `O2.pics` and run again from the “Tukey=contrMat . . .” line to get the comparisons of:

Pictures: No Music: Female-Male

Pictures: Music: Female-Male

Note: While I was doing this, I found an error in the “cell=lm . . .” line (even though I got an output for the last two lines with `summary()` and `confint()` so I didn’t think I had any problem). However, when I saw that my CIs were the same for the O2.pics data as for the O2.nopics data, I knew something was wrong. That’s when I looked back at my code and saw the error notice). I figured out what was wrong by just putting objects in the R console to see what was in them, such as `O2.nopics$gender`, and looking at my objects. Eventually, I figured out that I had used the wrong specification for my levels when I divided up the data into the `O2.nopics` and `O2.pics` subsets, and so those datasets had no data in them! I have no idea how I even got confidence intervals from my runs without any data in my datasets, but in any case I figured out the problem by looking at the building blocks of the code. If you have trouble running the code for your own data, the first thing to do is to make sure the code is absolutely the same as what I have. It’s probably best to run it for my data to make sure it works that way, then copy it for your own data. Make sure you have changed only the places that need to be changed. Then, if there
are still problems, start looking at the building blocks of the code, such as your variables (like `O2.pics$gender`) and the parts of the code (such as K1, K2, K, etc.).

#Pictures, music, gender

Tukey=contrMat(table(O2.pics$gender),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1)=paste(levels(O2.pics$musict2)[1], rownames(K1), sep=":")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(O2.pics$musict2)[2],rownames(K2),sep=":")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
O2.pics$gm=with(O2.pics, interaction(gender,musict2))
cell=lm(gainscore~gm-1, data=O2.pics)
summary(glht(cell, linfct=K))
confint(glht(cell,linfct=K))

Now change the results by switching the order of music and gender in the code:

#No Pictures, gender, music

Tukey=contrMat(table(O2.nopics$musict2),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1)=paste(levels(O2.nopics$gender)[1], rownames(K1), sep=":")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(O2.nopics$gender)[2],rownames(K2),sep="::")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
O2.nopics$gm=with(O2.nopics, interaction(musict2,gender))
cell=lm(gainscore~gm-1, data=O2.nopics)
summary(glht(cell, linfct=K))
confint(glht(cell,linfct=K))

This gives:

No pics: Male: No music-Music
No Pics: Female: No music-music

Now change the dataset to O2.pics:
#Pictures, gender, music
Tukey=contrMat(table(O2.pics$musict2),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1)=paste(levels(O2.pics$gender)[1], rownames(K1), sep="::")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(O2.pics$gender)[2],rownames(K2),sep="::")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
O2.pics$gm=with(O2.pics, interaction(musict2,gender))
\begin{verbatim}
cell=lm(gainscore~gm-1, data= O2.pics)
summary(glht(cell, linfct=K))
confint(glht(cell,linfct=K))

This gives:

Pics: Male: No music-Music
Pics: Female: No music-Music

Repeat this process by dividing up the data now between music and no music. Make sure when
you subset the data that you check the exact wording of the different levels of your variable so
you specify it exactly. Otherwise you will have an empty dataset. We now have 8 different
contrasts, 4 with Gender compared and 4 with Music compared. We just need to get 4 more
comparisons with Pictures compared.

O2.male<-subset(obarow2, subset=gender=="male")
O2.female<-subset(obarow2, subset=gender=="female")
str(O2.male)
str(O2.female)

#Male, music, pictures
Tukey=contrMat(table(obarow2$picturest2),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))
\end{verbatim}
rownames(K1)=paste(levels(obarow2$musict2)[1], rownames(K1), sep="::")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(obarow2$musict2)[2],rownames(K2),sep="::")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
obarow2$gm=with(obarow2, interaction(picturest2,musict2))
cell=lm(gainscore~gm-1, data=obarow2)
summary(glht(cell, linfct=K))
confint(glht(cell,linfct=K))

This gives:

Male: No Music: Pictures-no pictures

Male: Music: Pictures-no pictures

#Female, music, pictures
Tukey=contrMat(table(O2.female$picturest2),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey))))
rownames(K1)=paste(levels(O2.female$musict2)[1], rownames(K1), sep="::")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(O2.female$musict2)[2],rownames(K2),sep="::")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
```
O2.female$gm = with(O2.female, interaction(picturest2, musict2))
cell = lm(gainscore ~ gm - 1, data = O2.female)
summary(glht(cell, linfct = K))
confint(glht(cell, linfct = K))
```

This gives:

Female: No Music: Pictures-no pictures
Female: Music: Pictures-no pictures

**Results:**

Results are from the three-way contrasts (from R, and these are different than SPSS):

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th>95% CI</th>
</tr>
</thead>
<tbody>
<tr>
<td>No pictures</td>
<td>No music</td>
<td>Female: Male</td>
<td>[-2.30, 1.34]</td>
</tr>
<tr>
<td>Music</td>
<td>Female: Male</td>
<td></td>
<td>[-2.48, 1.48]</td>
</tr>
<tr>
<td>Pictures</td>
<td>No music</td>
<td>Female: Male</td>
<td>[-2.25, 2.58]</td>
</tr>
<tr>
<td></td>
<td>Music</td>
<td>Female: Male</td>
<td>[-2.69, 2.69]</td>
</tr>
<tr>
<td></td>
<td>Male</td>
<td>Music: No Music</td>
<td>[-1.09, 2.23]</td>
</tr>
<tr>
<td></td>
<td>Female</td>
<td>Music: No Music</td>
<td>[-1.57, 2.66]</td>
</tr>
<tr>
<td>Pictures</td>
<td>Male</td>
<td>Music: No Music</td>
<td>[-2.74, 2.74]</td>
</tr>
<tr>
<td></td>
<td>Female</td>
<td>Music: No Music</td>
<td>[-2.53, 2.19]</td>
</tr>
<tr>
<td>Male</td>
<td>No Music</td>
<td>Pictures: No Pictures</td>
<td>[-2.37, 1.70]</td>
</tr>
<tr>
<td></td>
<td>Music</td>
<td>Pictures: No Pictures</td>
<td>[-3.38, 1.58]</td>
</tr>
</tbody>
</table>
All of the CIs go through zero and none are statistical. None of the CIs are wildly wide but most center quite symmetrically around zero and so there is not much hope that with larger Ns we would find much difference.

**Second Step: Two-way Contrasts**

We already know what all of the two-way interactions are—they were listed in the terms of the regression equation, and are: Gender*MusicT2, Gender*PicturesT2, and MusicT2*PicturesT2.

For each of these two-way interactions, we will get 2 results when we run it one way, and 2 results when we run it the other way. For example, for the interaction between Gender and Music, we would get:

Male: Music-No Music
Female: Music-No Music

But if we switched the order, it would be a different comparison:

Music: Male-female
No music: Male-female

So we are looking for 4 results for each of the three two-way interactions (and that’s ONE complicated sentence!).
SPSS Instructions:

Go back to the Analyze > General Linear Model > Univariate choice. Press the “Reset” button at the bottom to reset all of the buttons (this is just to keep the multitude of output a little simpler!). Enter GAINSCORET2 in Dependent box, and GENDER, MUSICT2 and PICTURET2 in the Fixed effects box. Click the Model button and change to Type II sums of squares. Press Continue. Open the “Options” button and in the box under “Factor(s) and Factor Interactions” move the parts of your ANOVA equation that involve two-way interactions to the right to the “Display means for” box. Press Continue.

Press the “Paste” button at the bottom of the dialogue box, which brings up the Syntax Editor. You will find three lines that say EMMEANS. For each one add the command COMPARE( ) twice to it, right after the original line, with each variable of the two in last position:

/EMMEANS=TABLES(gender*musict2)

/EMMEANS=TABLES(gender*musict2)COMPARE(musict2)
/EMMEANS=TABLES(gender*musict2)COMPARE(gender)
/EMMEANS=TABLES(gender*picturest2)
/EMMEANS=TABLES(gender*picturest2)COMPARE(picturest2)
/EMMEANS=TABLES(gender*picturest2)COMPARE(gender)
/EMMEANS=TABLES(musict2*picturest2)
/EMMEANS=TABLES(musict2*picturest2)COMPARE(picturest2)
/EMMEANS=TABLES(musict2*picturest2)COMPARE(musict2)
The line with COMPARE(MusicT2) will give 2 comparisons:

Male: No music-music
Female: No music-music

The line with COMPARE(gender) will give 2 comparisons:

No Music: Male-female
Music: Male-female

And so forth.

Once all of the syntax is ready, choose RUN > ALL. By the way, should you have to run this syntax more than once you will see that it accumulates so you get several runs of the UNIANOVA. You can always highlight the run that you are interested in and then run just that part (RUN > SELECTION).

**R Instructions:**

Basically, we’re just going to run the same commands as we did for the three-way comparisons, but instead of using the dataset that was split, we’ll just use `obarow2`.

Now run the pairwise comparisons using the `multcomp` package:
library(multcomp)

# music, gender
Tukey=contrMat(table(obarow2$gender),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1)=paste(levels(obarow2$musict2)[1], rownames(K1), sep=":")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(obarow2$musict2)[2],rownames(K2),sep=":")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
obarow2$gm=with(obarow2, interaction(gender,musict2))
cell=lm(gainscore~gm-1, data=obarow2)
summary(glht(cell, linfct=K))
confint(glht(cell,linfct=K))

This code will give the 95% CIs for the comparisons of:

No Music: Female-Male
Music: Female-Male

Now change the results by switching the order of music and gender in the code:

# gender, music
Tukey=contrMat(table(obarow2$musict2),"Tukey")
K1 = cbind(Tukey, matrix(0, nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1) = paste(levels(obarow2$gender)[1], rownames(K1), sep=":")
K2 = cbind(matrix(0, nrow=nrow(Tukey), ncol=ncol(Tukey)), Tukey)
rownames(K2) = paste(levels(obarow2$gender)[2], rownames(K2), sep=":")
K = rbind(K1, K2)

colnames(K) = c(colnames(Tukey), colnames(Tukey))
obarow2$gm = with(obarow2, interaction(musict2, gender))
cell = lm(gainscore ~ gm - 1, data=obarow2)
summary(glht(cell, linfct=K))
confint(glht(cell, linfct=K))

This gives:

Male: No music-Music
Female: No music-music

# music, pictures
Tukey = contrMat(table(obarow2$picturest2), "Tukey")
K1 = cbind(Tukey, matrix(0, nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1) = paste(levels(obarow2$musict2)[1], rownames(K1), sep=":")
K2 = cbind(matrix(0, nrow=nrow(Tukey), ncol=ncol(Tukey)), Tukey)
rownames(K2) = paste(levels(obarow2$musict2)[2], rownames(K2), sep=":")
K = rbind(K1, K2)
No Music: Pictures-no pictures

Music: Pictures-no pictures

#pictures, music

Tukey=contrMat(table(obarow2$musict2),"Tukey")
K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))
rownames(K1)=paste(levels(obarow2$picturest2)[1], rownames(K1), sep=":")
K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)
rownames(K2)=paste(levels(obarow2$picturest2)[2],rownames(K2),sep=":")
K=rbind(K1, K2)
colnames(K)=c(colnames(Tukey), colnames(Tukey))
obarow2$gm=with(obarow2, interaction(musict2,picturest2))
cell=lm(gainscore~gm-1, data=obarow2)
summary(glht(cell, linfct=K))
confint(glht(cell,linfct=K))
This gives:

No Pictures: Music-No music

Pictures: Music-No music

#gender, pictures

Tukey=contrMat(table(obarow2$picturest2),"Tukey")

K1=cbind(Tukey, matrix(0,nrow=nrow(Tukey), ncol=ncol(Tukey)))

rownames(K1)=paste(levels(obarow2$gender)[1], rownames(K1), sep=":")

K2=cbind(matrix(0,nrow=nrow(Tukey),ncol=ncol(Tukey)),Tukey)

rownames(K2)=paste(levels(obarow2$gender)[2],rownames(K2),sep=":")

K=rbind(K1, K2)

colnames(K)=c(colnames(Tukey), colnames(Tukey))

obarow2$gm=with(obarow2, interaction(picturest2,gender))

cell=lm(gainscore~gm-1, data=obarow2)

summary(glht(cell, linfct=K))

confint(glht(cell,linfct=K))

This gives:

Male: Pictures-no pictures

Female: Pictures-no pictures
# pictures, gender

```r
Tukey = contrast(table(obarow2$gender), "Tukey")
K1 = cbind(Tukey, matrix(0, nrow = nrow(Tukey), ncol = ncol(Tukey)))
rownames(K1) = paste(levels(obarow2$picturest2)[1], rownames(K1), sep = "::")
K2 = cbind(matrix(0, nrow = nrow(Tukey), ncol = ncol(Tukey)), Tukey)
rownames(K2) = paste(levels(obarow2$picturest2)[2], rownames(K2), sep = "::")
K = rbind(K1, K2)
colnames(K) = c(colnames(Tukey), colnames(Tukey))
obarow2$gm = with(obarow2, interaction(gender, picturest2))
```

```r
cell = lm(gainscore ~ gm - 1, data = obarow2)
summary(glht(cell, linfct = K))
confint(glht(cell, linfct = K))
```

This gives:

No Pictures: Female-male

Pictures: Female-male

**Results:**

(from SPSS, and these differ from R)

<table>
<thead>
<tr>
<th></th>
<th>95% CI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Male</td>
<td>No music-Music</td>
</tr>
<tr>
<td>Female</td>
<td>No music-Music</td>
</tr>
<tr>
<td>--------</td>
<td>---------------</td>
</tr>
<tr>
<td>No Music</td>
<td>Male-Female</td>
</tr>
<tr>
<td>Music</td>
<td>Male-Female</td>
</tr>
<tr>
<td>Male</td>
<td>No pictures-pictures</td>
</tr>
<tr>
<td>Female</td>
<td>No pictures-pictures</td>
</tr>
<tr>
<td>No Pictures</td>
<td>Male-Female</td>
</tr>
<tr>
<td>Pictures</td>
<td>Male-Female</td>
</tr>
<tr>
<td>No Music</td>
<td>No pictures-pictures</td>
</tr>
<tr>
<td>Music</td>
<td>No pictures-pictures</td>
</tr>
<tr>
<td>No Pictures</td>
<td>No music-Music</td>
</tr>
<tr>
<td>Pictures</td>
<td>No music-Music</td>
</tr>
</tbody>
</table>

Results are exactly the same as for the three-way interactions: all of the CIs go through zero and none are statistical. None of the CIs are wildly wide but most center quite symmetrically around zero and so there is not much hope that with larger Ns we would find much difference.

Remember that we don't need to do any comparisons for the main effects as there are only two levels. Thus, the analysis of contrasts for this dataset is done and there were no effects found for music, pictures, or gender.

2 Larson-Hall and Connell (2005)

Use the LarsonHall.Forgotten.sav file, imported in R as forget.
a. Examine the Data Visually and Numerically

**SPSS Instructions:**

For boxplots, histograms and numerical values from one command, choose ANALYZE > DESCRIPTIVE STATISTICS > EXPLORE. Put the one dependent variable of SENTENCEACCENT in the “Dependent List” box. Put the two independent variables of SEX and STATUS in the “Factor List.” Open the “Plots” button and tick off “Stem-and-leaf” (we don’t really look at these) and tick on “Histogram.” Press Continue and then OK. This configuration of the Explore command will produce numerical descriptive stats including skewness and kurtosis numbers, histograms and boxplots for the dependent variable split by each of the 2 independent variables at one time.

**R Instructions:**

To look at boxplots:

```r
library(HH)
interaction2wt(forget$sentenceaccent~forget$sex*forget$status,par.strip.text=list(cex=.6),
main.in="Effects of gender and immersion status on sentence accent ratings",
box.ratio=.3, rot=c(90,90),
factor.expressions=
  c(sex=expression("Gender"),
status=expression("Status")),
resposnelab.expression="Sentence\nacent")
```

To see numerical results for skewness and kurtosis, use R Commander: STATISTICS > SUMMARIES > NUMERICAL SUMMARIES (make sure forget is the active dataset). Choose the
sentenceaccent variable and open the “Summarize by groups” button and pick sex first. Go to the “Statistics” tab and tick off everything then tick on Skewness and Kurtosis. Press “Apply,” then go back to the “Data” tab and open the “Summarize by groups” button and pick status last, and this time hit OK.

The R code for the first one is:
```r
numSummary(forget[,"sentenceaccent"], groups=forget$status,
statistics=c("skewness", "kurtosis"), quantiles=c(0,.25,.5,.75,1), type="2")
```

To look at histograms, in R Commander choose GRAPHS > HISTOGRAM. Choose sentenceaccent as the “Variable,” then open the “Plot by groups” button and choose sex first. Press “Apply,” then go back to the “Data” tab and open the “Plot by groups” button and pick status last, and this time hit OK.

The R code for the first one is:
```r
with(forget, Hist(sentenceaccent, groups=sex, scale="frequency",
breaks="Sturges", col="darkgray"))
```

**Results:**

The boxplots for sex show outliers, and variances seem to be quite different for males and females, but data seems symmetric. For status boxplots have no outliers, variances are not so different, and boxes seem symmetrically distributed. None of the histograms looks exactly normal but none seem too skewed either. The numerical summaries for skewness and kurtosis
show that the group of males had a skewness score over 1, and a high kurtosis score along with that. However, for the data split by STATUS there were no problems with skewness or kurtosis.

**b. Run the Factorial ANOVA with Traditional Output**

**SPSS Instructions:**

To perform the factorial two-way ANOVA (3×2 in this case), **ANALYZE > GENERAL LINEAR MODEL > UNIVARIATE.** Enter **SENTENCEACCENT** in Dependent box, and **SEX** and **STATUS** in the Fixed effects box. **Click the MODEL button and change to Type II SS.** Press Continue. Open the **PLOTS** button. Try a couple of different plot configurations, putting the variables in the boxes in different order. Press Continue. Open the **SAVE** button and tick “Cook’s distance” under “Diagnostics,” and “Unstandardized” under “Residuals.” Press **CONTINUE.** Open the **OPTIONS** button and under “Display,” tick “Descriptive Statistics,” “Homogeneity tests,” “Spread vs. level plot,” and “Residual plot.” We’ll want post-hocs for **STATUS** as it has 3 levels, so move that term to the right in the window, tick the “Compare Main Effects” box, and leave the post-hoc set for LSD (there are only 3 groups). Press **CONTINUE** and **OK** to run the analysis.

**R Instructions:**

To perform the factorial two-way ANOVA (3×2 in this case), in **R Commander,** make sure the **forget** dataset is active and choose **STATISTICS > MEANS > MULTI-WAY ANOVA.** In the “Factors” box choose **sex** and **status.** For the “Response Variable” box, choose **sentenceaccent.** Press **OK.** Note that because the model is called by the generic automatic label “AnovaModel.1,” and you probably have some of those still rattling around, you may get a warning that asks you if you want to overwrite the previous model. On the other hand, if you are doing a number of these
exercises in a row you may get a sequentially numbered model, like AnovaModel.2, so just keep track of what your model is called. Change the model name if you don’t want to overwrite previous models, or just click OK if you are done with all previous models.

The last line of the Anova table shows that the Residuals=35.19, which is not that much larger relative to the sums of squares, which means that the model does account for a good amount of the variation in the data. To get the R² value, call for the summary of the model:

```r
summary(AnovaModel.1)
```

To examine regression assumptions, just plot the ANOVA model that was created (it will produce 4 plots, so if you want, run the first line here to put all 4 plots on one page):

```r
par(mfrow = c(2, 2), oma = c(0, 0, 2, 0))
plot(AnovaModel.1)
par(mfrow = c(1, 1)) #to return to normal
```

For this model I got a warning:

```
Warning: not plotting observations with leverage one: 36
```

This seems to mean I have a rather extreme outlier if its leverage is 1.0.
Results:

Descriptive statistics:

<table>
<thead>
<tr>
<th></th>
<th>Mean</th>
<th>SD</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Female</td>
<td>Non</td>
<td>3.16</td>
<td>0.96</td>
</tr>
<tr>
<td></td>
<td>Late</td>
<td>3.24</td>
<td>0.93</td>
</tr>
<tr>
<td></td>
<td>Early</td>
<td>4.58</td>
<td>1.16</td>
</tr>
<tr>
<td>Male</td>
<td>Non</td>
<td>1.94</td>
<td>0.67</td>
</tr>
<tr>
<td></td>
<td>Late</td>
<td>2.19</td>
<td>0.09</td>
</tr>
<tr>
<td></td>
<td>Early</td>
<td>4.75</td>
<td>NA</td>
</tr>
</tbody>
</table>

Obviously it’s a real problem for this analysis if there is only one male participant in the Early group! It would be a good reason why no interaction was seen between the status and sex variables.

Levene’s test for equality of error variances has a $p$-value of $p = .27$, which would indicate no problem with heteroscedasticity.

The three terms in the regression equation (values are equal in SPSS or R):

- Sex       $F_{1,38} = 6.56, p = .015$
- Status    $F_{2,38} = 10.95, p<.0005$
- Sex*Status $F_{2,38} = 0.79, p = 0.46$

$R^2=.54$, Adjusted $R^2=.47$
The Tests of Between-Subjects Effects show that SEX is statistical as well as STATUS but not the interaction between them. The effect size of the model is $R^2 = .54$, which explains quite a lot of the variance (it is a large effect size!).

Pairwise comparisons between the three levels of status showed the following 95% CI of the difference in means:

<table>
<thead>
<tr>
<th>Comparison</th>
<th>95% CI</th>
<th>Cohen's d</th>
<th>Mean</th>
<th>SD</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non Vs. Late</td>
<td>[-1.06, 0.73]</td>
<td>.61</td>
<td>Non</td>
<td>2.51</td>
<td>1.01</td>
</tr>
<tr>
<td>Non Vs. Early</td>
<td>[-3.24, -0.99]</td>
<td>1.95</td>
<td>Late</td>
<td>3.10</td>
<td>0.93</td>
</tr>
<tr>
<td>Late Vs. Early</td>
<td>[-3.20, -0.70]</td>
<td>1.45</td>
<td>Early</td>
<td>4.59</td>
<td>1.12</td>
</tr>
</tbody>
</table>

Additionally, we’d like to know the mean scores of these groups in order to interpret the CIs of the difference in means. The descriptive statistics above are too fine-grained now, so to get the mean scores of these groups:

**In SPSS, go** to **ANALYZE > DESCRIPTIVE STATISTICS > EXPLOR**E. Move **SentenceAccent** to the right to the “Dependent List” box, then move **SEX** and **STATUS** to the right under “Factor List.” We only want numbers so tick on the “Statistics” button in the “Display” area of the main dialogue box, and press OK.

**In R Commander, go** to **STATISTICS > SUMMARIES > NUMERICAL SUMMARIES** and pick **sentenceaccent**. Click on the “Summarize by” button and choose **status**. Click on the
“Statistics” tab and make sure “Mean and “Standard deviation” are the only things ticked. Press OK.

I used an online calculator to calculate Cohen’s d value using the means and standard deviations.

The group with the highest mean score is the Early group and the CIs show that we can have 95% confidence that the actual mean difference between the groups lies in this interval. At the worst, the Early group score around at least 1 point better than either the Late or Non group (since there are only 7 points in the accent rating scale, 1 point is a good amount), and at their best may score closer to 3 points. However, the two groups who started learning English later in life (Non and Late) have a CI that passes through zero and is centered pretty well around zero, although it does have a medium-size Cohen’s d effect size of $d = .61$. So living abroad (Late group) helped this group score better than those who never did live abroad, but did not give them as much advantage as those who learned English at an early age.

The ANOVA output told us that males and females performed differently. However, we need to look at mean scores for males and females to see who scored higher than the other group. I have already done this for SPSS (above).

**In R Commander, go to Statistics > Summaries > Numerical Summaries and pick sentenceaccent.** Click on the “Summarize by” button and choose sex. Click on the “Statistics” tab and make sure “Mean” and “Standard deviation” are the only things ticked. Press OK.
<table>
<thead>
<tr>
<th></th>
<th>Mean</th>
<th>SD</th>
<th>N</th>
<th>Cohen’s d</th>
</tr>
</thead>
<tbody>
<tr>
<td>Female</td>
<td>3.75</td>
<td>1.21</td>
<td>33</td>
<td>1.35</td>
</tr>
<tr>
<td>Male</td>
<td>2.24</td>
<td>1.01</td>
<td>11</td>
<td></td>
</tr>
</tbody>
</table>

The mean scores show that females scored more highly than males, but there were also 3 times as many females so it probably would not be a good idea to rely too heavily on this dataset to conclude that males have worse sentence accent than females, in general.


Use BEQ.Swear.sav file. Import into R as `beq.swear`.

**a. Examine the Data Visually and Numerically**

**SPSS Instructions:**

For boxplots, histograms and numerical values from one command, choose **ANALYZE > DESCRIPTIVE STATISTICS > EXPLORE**. Put the one dependent variable of WEIGHT2 in the “Dependent List” box. Put the two independent variables of CONTEXTACQUISITIONSEC and L1DOMINANCE in the “Factor List.” Open the “Plots” button and tick off “Stem-and-leaf” (we don’t really look at these) and tick on “Histogram.” Press Continue and then OK. This configuration of the Explore command will produce numerical descriptive stats including skewness and kurtosis numbers, histograms and boxplots for the dependent variable split by each of the 2 independent variables at one time.

**R Instructions:**

To look at boxplots:
library(HH)
interaction2wt(beq.swear$weight2~beq.swear$contextacquisitionsec*beq.swear$l1dominance,par.strip.text=list(cex=.6), main.in="Effects of L2 context of acquisition and L1 dominance on the weight given to swear words in L2", box.ratio=.3, rot=c(90,90), factor.expressions=c(contextacquisitionsec=expression("L2 context of acquisition"), l1dominance=expression("L1 dominance")), resonselab.expression="Weight given into swearing")

When I run this, I don’t see lines, which means I have NAs in my data. I’ll make a new file without any:

new.beq.swear<-na.omit(beq.swear)

Now when I run the code again I can see all of the lines.

To see numerical results for skewness and kurtosis, use R Commander: STATISTICS > SUMMARIES > NUMERICAL SUMMARIES (make sure beq.swear is the active dataset). Choose the weight2 variable and open the “Summarize by groups” button and pick contextacquisitionsec first. Go to the “Statistics” tab and tick off everything then tick on Skewness and Kurtosis. Press “Apply,” then go back to the “Data” tab and open the “Summarize by groups” button and pick l1dominance last, and this time hit OK.
The R code for the first one is:

```r
cumSummary(beq.swear["weight2"], groups=beq.swear$contextacquisitionsec,
statistics=c("mean", "sd", "IQR", "quantiles"), quantiles=c(0,.25,.5,.75,1))
```

To look at histograms, in R Commander choose GRAPHS > HISTOGRAM. Choose `weight2` as the “Variable,” then open the “Plot by groups” button and choose `contextacquisitionsec` first. Press “Apply,” then go back to the “Data” tab and open the “Plot by groups” button and pick `l1dominance` last, and this time hit OK.

The R code for the first one is:

```r
with(beq.swear, Hist(weight2, groups=contextacquisitionsec,
scale="frequency", breaks="Sturges", col="darkgray"))
```

**Results:**

From the boxplots, for context of acquisition, variances seem to be equal among the 3 categories but data is skewed for two levels, as can also be seen in the histograms where there is more data to the right (negative skewness) than would be expected by a normal distribution. For L1 dominance, boxplots show a number of outliers for respondents who say their L1 is dominance (YES) or their L1 plus another language is dominant (YESPLUS). All categories for L1 Dominance are also non-symmetrically distributed, which can also be seen in the histograms. For the numerical summaries, skewness numbers are not over 1 for the L2 context of acquisition, nor for L1 dominance. Data do not meet the assumptions of ANOVA but we will continue.
b. Run the Factorial ANOVA with Traditional Output

**SPSS Instructions:**

To perform the factorial two-way ANOVA (3×3 in this case), choose **ANALYZE > GENERAL LINEAR MODEL > UNIVARIATE.** Enter **weight2** in the Dependent box, and **CONTEXTACQUISITIONSEC and L1DOMINANCE** in the Fixed effects box. Click the **MODEL** button and change to **Type II SS.** Press **CONTINUE.**

Open the **PLOTS** button. Try a couple of different plot configurations, putting the variables in the boxes in different order. Press **CONTINUE.**

Open the **SAVE** button and tick “Cook’s distance” under “Diagnostics,” and “Unstandardized” under “Residuals.” Press **CONTINUE.**

Open the **OPTIONS** button and under “Display,” tick “Descriptive Statistics,” “Homogeneity tests,” “Spread vs. level plot,” and “Residual plot.” We’ll want post-hocs for both **CONTEXTACQUISITIONSEC and L1DOMINANCE** as they both have 3 levels, so move those terms to the right in the window, tick the “Compare Main Effects” box, and leave the post-hoc set for LSD (there are only 3 groups). Press **CONTINUE** and then **OK** to run the analysis.

**R Instructions:**

To perform the factorial two-way ANOVA (3×3 in this case), in R Commander, make sure the **beq.swear** dataset is active and choose **STATISTICS > MEANS > MULTI-WAY ANOVA.** In the “Factors” box choose **contextacquisitionsec and l1dominance.** For the “Response Variable” box, choose **weight2.** Press OK. Note that because the model is called by the generic automatic label “AnovaModel.1,” and you probably have some of those still rattling around, you may get a warning that asks you if you want to overwrite the previous model. On the other hand, if you are doing a number of these exercises in a row you may get a sequentially numbered model, like
AnovaModel.2, so just keep track of what your model is called. Change the model name if you don't want to overwrite previous models, or just click OK if you are done with all previous models.

The last line of the Anova table shows that the Residuals=1176.72, which is a large number relative to the sums of squares (none of which are larger than 61), which means that the model does not account for much of the variation in the data. To get the $R^2$ value, call for the summary of the model in the R console:

```r
summary(AnovaModel.1) #or whatever your model is called
```

To examine regression assumptions, just plot the ANOVA model that was created (it will produce 4 plots, so if you want, run the first line here to put all 4 plots on one page):

```r
par(mfrow = c(2, 2), oma = c(0, 0, 2, 0))
plot(AnovaModel.1)
par(mfrow = c(1, 1)) #to return to normal
```
Results:

Descriptive statistics:

<table>
<thead>
<tr>
<th>Context of Acquisition</th>
<th>Mean</th>
<th>SD</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Both</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Not L1 dominant</td>
<td>3.85</td>
<td>1.20</td>
<td>52</td>
</tr>
<tr>
<td>Yes L1 dominant</td>
<td>3.57</td>
<td>1.09</td>
<td>196</td>
</tr>
<tr>
<td>L1 + another lge</td>
<td>3.72</td>
<td>1.05</td>
<td>184</td>
</tr>
<tr>
<td>+ another lge dominant</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Instructed</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Not L1 dominant</td>
<td>3.52</td>
<td>1.16</td>
<td>25</td>
</tr>
<tr>
<td>Yes L1 dominant</td>
<td>3.13</td>
<td>1.21</td>
<td>240</td>
</tr>
<tr>
<td>L1 + another lge</td>
<td>3.17</td>
<td>1.08</td>
<td>98</td>
</tr>
<tr>
<td>+ another lge dominant</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Naturalistic</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Not L1 dominant</td>
<td>3.65</td>
<td>1.39</td>
<td>20</td>
</tr>
<tr>
<td>Yes L1 dominant</td>
<td>3.89</td>
<td>1.07</td>
<td>74</td>
</tr>
<tr>
<td>L1 + another lge</td>
<td>3.81</td>
<td>1.08</td>
<td>53</td>
</tr>
<tr>
<td>+ another lge dominant</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Levene’s test for equality of error variances has a \( p \)-value of \( p = .19 \), which would indicate no problem with heteroscedasticity.
The three terms in the regression equation (values are equal in SPSS or R):

<table>
<thead>
<tr>
<th>Term</th>
<th>F-value</th>
<th>p-value</th>
</tr>
</thead>
<tbody>
<tr>
<td>L2 context of acquisition</td>
<td>$F_{2,933} = 24.23$, $p &lt; .0005$</td>
<td></td>
</tr>
<tr>
<td>L1 dominance</td>
<td>$F_{2,933} = 1.44$, $p = .238$</td>
<td></td>
</tr>
<tr>
<td>L2 context of acquisition* L1 dominance</td>
<td>$F_{4,933} = 0.95$, $p = .432$</td>
<td></td>
</tr>
<tr>
<td>$R^2 = .06$, Adjusted $R^2 = .05$</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Tests of Between-Subjects Effects show that CONTEXTACQUISITIONSEC is statistical, but not STATUS nor the interaction between the two variables. The effect size of the model is $R^2 = .06$, which means that this equation does not explain very much of the variance in the model (it is a very small effect size!).

Pairwise comparisons between the three levels of status showed the following 95% CI of the difference in means:

<table>
<thead>
<tr>
<th>Comparison:</th>
<th>95% CI</th>
<th>Cohen’s d</th>
<th>Mean</th>
<th>SD</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Both vs. Instr</td>
<td>[0.23, 0.65]</td>
<td>.44</td>
<td>Both</td>
<td>3.67</td>
<td>1.09</td>
</tr>
<tr>
<td>Both vs. Nat</td>
<td>[-0.32, 0.18]</td>
<td>.15</td>
<td>Instr</td>
<td>3.17</td>
<td>1.17</td>
</tr>
<tr>
<td>Instr vs. Nat</td>
<td>[-0.78, -0.24]</td>
<td>.58</td>
<td>Natl</td>
<td>3.83</td>
<td>1.11</td>
</tr>
</tbody>
</table>
Additionally, we’d like to know the mean scores of these groups in order to interpret the CIs of the difference in means. The descriptive statistics above are too fine-grained now, so to get the mean scores of these groups:

**In SPSS,** go to **ANALYZE > DESCRIPTIVE STATISTICS > EXPLORE.** Move weight2 to the right to the “Dependent List” box, then move CONTEXTACQUISITIONSEC and L1DOMINANCE to the right under “Factor List.” We only want numbers so tick on the “Statistics” button in the “Display” area of the main dialogue box, and press OK.

**In R Commander,** go to **STATISTICS > SUMMARIES > NUMERICAL SUMMARIES** and pick `weight2`. Click on the “Summarize by” button and choose `status`. Click on the “Statistics” tab and make sure “Mean and “Standard deviation” are the only things ticked. Press OK.

I used an online calculator to calculate Cohen’s d value using the means and standard deviations.

The group with the highest mean score is the Naturalistic group and the CIs show that we can have 95% confidence that the actual mean difference between the groups lies in this interval. Remember that the scale is only 5 points, so differences are going to be small. The Instructed group is different from both the Naturalistic group and those who learned both ways, and their mean score is the lowest. The CIs for the differences between the Instructed group vs. Both and for the Instructed group vs. Naturalistic are quite similar (one is negative and one is positive but that’s just an artifact of which score is subtracted from which). At its worst the groups would only be different by about ¼ of a point (.25) but at their best they would only be better by about
¾ of a point (.75). The CIs are fairly narrow and precise because of the large N involved. The
effect sizes are modest.

The Naturalistic group and both group are too similar to each other to be found different, and the
CI goes through zero and is fairly close to zero. Effect sizes show the smallest effect size for
differences between these groups. It thus seems that learning an L2 naturalistically or both
naturalistically and with instruction results in speakers putting the same amount of weight to
swear words in their L2.

Although the L2 context of acquisition plays a role, my view of the results would be that we
have not captured here the real factors that explain the variance in how participants view the
emotional force of swear words in their L2 (Dewaele, 2004 essentially finds this same thing by
using one-way ANOVAs with instructed context and gender separately).

4 Eysenck (1974)

Use the dataset HowellChp13Data.LongForm.sav. Import into R as `howell13`.

This analysis will be different from any of the previous ones in the Application Activity because
we need to use planned comparisons (see Section 10.5.3).

**a. Put the dataset in the correct form**
In Section 10.5.3 I explained that in order to perform a planned comparison on a factorial
ANOVA I basically had to change it into a format for a one-way ANOVA by creating just ONE
factor that coded for all of my variables. Thus, I will need to make a new variable for this dataset,
one that has (5 (task variables) ×2 (age levels)) = 10 categories. In the file as it is when you open it, there are 100 rows. We’ll need to keep the same number of rows but make a new variable (call it CATEGORY) which codes for the intersection of AGEGROUP and TASK.

**SPSS Instructions:**

I don’t know of a better way to do this than by hand in SPSS. Go to the “Variable View” tab and create a new variable called Category. Start labeling it from row 1 as 1. 1 will equal AgeGroup = 1, Task = 1. Put in 10 “1”s. At row 11, start entering the number 2. 2 will equal AgeGroup=2, Task = 1. And continue on in this manner, entering 10 rows of successive numbers until you have 10 groups of 10 numbers. Then go to “Variable View” and enter the “Values” for these numbers. So 1 = Old+Counting while 2 = Young+Counting and so on.

**R Instructions:**

Basically, I want to create a new column with 10 instances of each number from 1 to 10, and give each of these a new value. First, I’ll look at the levels of my variables in the original dataset:

```r
> names(howell13)
[1] "score" "agegroup" "task"
> levels(howell13$agegroup)
[1] "Old" "Young"
> levels(howell13$task)
[1] "Counting" "Rhyming" "Adjective" "Image" "Intentional"
```

I want to give the levels to my new variable in this order, so that 1 = Old+Counting while 2 = Young+Counting and so on. Getting information from Appendix A on Doing Things in R, I see that in order to add columns to a dataframe I should use the `cbind( )` command (this snippet is from Appendix A):
To make my new variable, which is a factor, I’ll need the \texttt{rep()} command (again, this snippet is from Appendix A):

\begin{verbatim}
I'm ready to try to make a new variable:

category=factor(rep(1:10, c(10,10,10,10,10,10,10,10,10,10)))
\end{verbatim}

Actually, you might think, there must be a faster way to do this! And if you read a little further down in this entry (“Creating a Factor” in Appendix A) you would see the \texttt{gl()} command. This is faster, and lets us specify the factor levels at the same time, like this:

\begin{verbatim}
category2=gl(10, 10, 100, labels=c("Old+Counting", "Young +Counting", "Old+Rhyming", "Young+Rhyming", "Old+Adj", "Young+Adj", "Old+Image", "Young+Image", "Old+Intention", "Young+Intention"))
\end{verbatim}

Whichever way you do it, when you finish, look at your variable! (I’ll show \texttt{category} since it’s smaller!)
Now cbind it to your dataset:

```r
newhowell13<-cbind.data.frame(category2, howell13)
str(newhowell13)
```

Verify that this your new variable is a factor with the `str()` command. If you use something like `category`, you’ll need to specify names for your levels with the `c()` command:

```r
levels(newhowell13$category)
#first check the names of the levels
[1] "1" "2" "3" "4" "5" "6" "7" "8" "9" "10"
levels(newhowell13$category)= c("Old+Counting", "Young +Counting", "Old+Rhyming", "Young+Rhyming", "Old+Adj", "Young+Adj", "Old+Image", "Young+Image", "Old+Intention", "Young+Intention")
```

**b. Perform the Planned Comparison for Question #1:**

1. Did the older group perform differently in each condition?

To answer this question we have to do a series of comparisons:

1. Old Counting vs. Old Rhyming
Thus, we will need to enter a +1 for the first group in each of the comparisons and a -1 for the second group in each of the comparisons. The following table shows the numbers we’ll need to enter for each planned comparison:

<table>
<thead>
<tr>
<th></th>
<th>Old Count</th>
<th>Young Count</th>
<th>Old Rhyme</th>
<th>Young Rhyme</th>
<th>Old Adj</th>
<th>Young Adj</th>
<th>Old Image</th>
<th>Young Image</th>
<th>Old Intention</th>
<th>Young Intention</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>+1</td>
<td></td>
<td>-1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>+1</td>
<td>-1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td>-1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-1</td>
<td></td>
<td>-1</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>+1</td>
<td>-1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td>-1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-1</td>
<td></td>
<td>-1</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-1</td>
<td></td>
<td>-1</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-1</td>
<td></td>
<td>-1</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>+1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>+1</td>
<td></td>
<td>-1</td>
<td></td>
</tr>
</tbody>
</table>

Enter in the numbers for each comparison as listed in this table along the row (adding in zeros where the cells are empty). Note that you don't need to put the “+” sign for the positive “1,” but you do need to put in a “-” sign for the negative “1.”
2 Did the intentional learning group (“Intentional” in the Task variable) result in higher recall on the Score variable than any of the incidental conditions (“Counting,” “Rhyming,” “Adjective” and “Image”) taken as a group for either the younger or older group?

Here we want to compare 4 groups to 1 group for first the older learners, then the younger learners, so we’ll put in a +1 for each of the 4 incidental groups and a -4 for the intentional group for two different comparisons like this:

<table>
<thead>
<tr>
<th></th>
<th>Old Count</th>
<th>Young Count</th>
<th>Old Rhyme</th>
<th>Young Rhyme</th>
<th>Old Adj</th>
<th>Young Adj</th>
<th>Old Image</th>
<th>Young Image</th>
<th>Old Intention</th>
<th>Young Intention</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>+1</td>
<td>+1</td>
<td>+1</td>
<td>+1</td>
<td>+1</td>
<td>-4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>+1</td>
<td>+1</td>
<td>+1</td>
<td>+1</td>
<td>+1</td>
<td>-4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Again, enter in the numbers for each comparison along the row (adding in zeros where the cells are empty).

Now we’re ready to try it out!

**SPSS Instructions:**

With your data set “HowellChp13Data.LongForm.sav” that has a new factor in it called CATEGORY, open the One-Way ANOVA (ANALYZE > COMPARE MEANS > ONE-WAY ANOVA) and put the Score variable in the “Dependent List” box and the newly created variable CATEGORY in the “Factor” box. Open the CONTRASTS button and enter in the numbers for each question as listed in the table for question #1. You’ll enter the 10 numbers in order, putting each number by turn in the “Coefficients” box and pressing the “Add” button after each one. When
you finish the row, push the “Next” button to go on to the next comparison. Press CONTINUE when you finish.

Open the Options button and tick the “Descriptive Statistics” box. Press CONTINUE. Press OK to run your analysis for Question #1.

In the output, you’ll want to check the box called “Contrast Coefficients” to make sure you filled in all of the coefficients correctly and that they match up with the table above for Question #1. You’ll only be able to look at $t$-test values, degrees of freedom and $p$-values for the 10 contrasts in the “Contrast Tests” box.

When you’re finished with Question #1, open up the same menu choice and press the “Reset” button. Again, put the SCORE variable in the “Dependent List” box and CATEGORY in the “Factor” box. Open the CONTRASTS button and enter in the numbers for each question as listed in the table for question #2. Open the Options button and tick the “Descriptive Statistics” box. Press Continue. Press OK to run your analysis for Question #2.

Again, make sure to check the box called “Contrast Coefficients” to make sure you filled in all of the coefficients correctly and that they match up with the table above for Question #2.

**R Instructions:**

Question #1:

For R we will create an object that defines our contrasts:
contr<-rbind("Count_Rhyme"=c(1,0,-1,0,0,0,0,0,0,0),
"Count_Adj"=c(1,0,0,0,-1,0,0,0,0,0), "Count_Image"=c(1,0,0,0,0,0,-1,0,0,0),
"Count_Intention"=c(1,0,0,0,0,0,0,0,-1,0), "Rhyme_Adj"=c(0,0,1,0,-1,0,0,0,0,0),
"Rhyme_Image"=c(0,0,1,0,0,-1,0,0,0,0), "Rhyme_Intention"=c(0,0,1,0,0,0,0,-1,0,0,0),
"Adj_Image"=c(0,0,0,0,1,0,-1,0,0,0), "Adj_Intention"=c(0,0,0,0,1,0,0,0,-1,0),
"Image_Intention"=c(0,0,0,0,0,1,0,-1,0,0))

To get the confidence intervals for these comparisons, first open the multcomp package and then create a regression model that models the score as a function of the category (which we named category2).

library(multcomp)

fit<-aov(score~category2, data=newhowell13)

Now call for the confidence intervals for the contrasts we specified above:

confint(glht(fit,linfct=mcp(category2=contr)))

plot(glht(fit,linfct=mcp(category2=contr))) #if you want, plot the contrasts too

summary(glht(fit,linfct=mcp(category2=contr))) #if you want p-values

For Question #2, here is the object we need that contains the contrasts:
contr2<-rbind("Old Incidental_Old Intentional"=c(1,0,1,0,1,0,1,0,-4,0),
"Young Incidental_Young Intentional"=c(0,1,0,1,0,1,0,1,0,-4))

The regression model is already fit, so just use the glht() command again, this time with the different contrast object:

confint(glht(fit,linfct=mcp(category2=contr2)))
plot(glht(fit,linfct=mcp(category2=contr2)))  # if you want, plot the contrasts too
summary(glht(fit,linfct=mcp(category2=contr2)))  # if you want p-values

Don’t forget to get descriptive statistics too (here’s one way):

with(newhowell13, (tapply(score, list(category2), mean, na.rm=TRUE)))  # means
with(newhowell13, (tapply(score, list(category2), sd, na.rm=TRUE)))  # sd
with(newhowell13, (tapply(score, list(category2), function(x) sum(!is.na(x))))))  # counts

Results:

Question #1:

Here are the SPSS descriptives for the N, mean and standard deviation for each category:
The contrasts showed that the older learners did not perform differently in each condition. For example, using the standard of $p > .05$ to judge, they did not perform differently on the Counting task vs. the Rhyming task (Contrast #1), nor did they perform better on Adjective vs. Imagery (Contrast #8), Adjective vs. Intention (Contrast #9), or Imagery vs. Intentional learning (Contrast #10). Here I reproduce the SPSS table with the $t$-values, df and $p$-values (under the “Sig.” column) for the “Does not assume equal variances” choice (I’ve used the Paint program to move the bottom part of the chart up and it is covering the “Assume equal variances” portion):

<table>
<thead>
<tr>
<th>Contrast</th>
<th>N</th>
<th>Mean</th>
<th>Std. Deviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Old+Counting</td>
<td>10</td>
<td>7.00</td>
<td>1.826</td>
</tr>
<tr>
<td>Young+Counting</td>
<td>10</td>
<td>6.50</td>
<td>1.434</td>
</tr>
<tr>
<td>Old+Rhyming</td>
<td>10</td>
<td>6.90</td>
<td>2.132</td>
</tr>
<tr>
<td>Young+Rhyming</td>
<td>10</td>
<td>7.50</td>
<td>1.555</td>
</tr>
<tr>
<td>Old+Adjective</td>
<td>10</td>
<td>11.00</td>
<td>2.494</td>
</tr>
<tr>
<td>Young+Adjective</td>
<td>10</td>
<td>14.80</td>
<td>3.490</td>
</tr>
<tr>
<td>Old+Image</td>
<td>10</td>
<td>13.40</td>
<td>4.502</td>
</tr>
<tr>
<td>Young+Image</td>
<td>10</td>
<td>17.60</td>
<td>2.591</td>
</tr>
<tr>
<td>Old+Intention</td>
<td>10</td>
<td>12.00</td>
<td>3.742</td>
</tr>
<tr>
<td>Young+Intention</td>
<td>10</td>
<td>19.30</td>
<td>2.869</td>
</tr>
<tr>
<td>Total</td>
<td>100</td>
<td>11.81</td>
<td>5.191</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value of Contrast</th>
<th>Std. Error</th>
<th>$t$</th>
<th>df</th>
<th>Sig. (2-tailed)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assume equal variances</td>
<td>1.00</td>
<td>1.267</td>
<td>.079</td>
<td>50</td>
</tr>
<tr>
<td>Does not assume equal variances</td>
<td>1.00</td>
<td>1.267</td>
<td>.079</td>
<td>50</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value of Contrast</th>
<th>Std. Error</th>
<th>$t$</th>
<th>df</th>
<th>Sig. (2-tailed)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assume equal variances</td>
<td>1.00</td>
<td>1.267</td>
<td>.079</td>
<td>50</td>
</tr>
<tr>
<td>Does not assume equal variances</td>
<td>1.00</td>
<td>1.267</td>
<td>.079</td>
<td>50</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value of Contrast</th>
<th>Std. Error</th>
<th>$t$</th>
<th>df</th>
<th>Sig. (2-tailed)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assume equal variances</td>
<td>1.00</td>
<td>1.267</td>
<td>.079</td>
<td>50</td>
</tr>
<tr>
<td>Does not assume equal variances</td>
<td>1.00</td>
<td>1.267</td>
<td>.079</td>
<td>50</td>
</tr>
</tbody>
</table>
For R we can get back confidence intervals, and the contrasts have even been labeled:

<table>
<thead>
<tr>
<th>Linear Hypotheses</th>
<th>Estimate</th>
<th>lwr</th>
<th>upr</th>
</tr>
</thead>
<tbody>
<tr>
<td>Count_Rhyme == 0</td>
<td>0.1000</td>
<td>-3.4268</td>
<td>3.6268</td>
</tr>
<tr>
<td>Count_Adj == 0</td>
<td>-4.0000</td>
<td>-7.5268</td>
<td>-0.4732</td>
</tr>
<tr>
<td>Count_Image == 0</td>
<td>-6.4000</td>
<td>-9.9268</td>
<td>-2.8732</td>
</tr>
<tr>
<td>Count_Intention == 0</td>
<td>-5.0000</td>
<td>-8.5268</td>
<td>-1.4732</td>
</tr>
<tr>
<td>Rhyme_Adj == 0</td>
<td>-4.1000</td>
<td>-7.6268</td>
<td>-0.5732</td>
</tr>
<tr>
<td>Rhyme_Image == 0</td>
<td>-6.5000</td>
<td>-10.0268</td>
<td>-2.9732</td>
</tr>
<tr>
<td>Rhyme_Intention == 0</td>
<td>-5.1000</td>
<td>-8.6268</td>
<td>-1.5732</td>
</tr>
<tr>
<td>Adj_Image == 0</td>
<td>-2.4000</td>
<td>-5.9268</td>
<td>1.1268</td>
</tr>
<tr>
<td>Adj_Intention == 0</td>
<td>-1.0000</td>
<td>-4.5268</td>
<td>2.5268</td>
</tr>
<tr>
<td>Image_Intention == 0</td>
<td>1.4000</td>
<td>-2.1268</td>
<td>4.9268</td>
</tr>
</tbody>
</table>

The confidence intervals show that the contrasts with the largest effects (where the lower limit was farthest away from 0) were the contrast between Counting and Imagery (lower limit = 2.87) and between Rhyming and Imagery (lower limit = 2.97). Indeed, the descriptives show that for the older group, Imagery led to the highest recall scores. More could be made of these CIs but I will stop here.

**Question #2:**

For SPSS, going by *p*-values only, if we do not assume equal variances, there was no difference for older learners in the number of words memorized when comparing all of the incidental
conditions to the intentional condition (t = -1.91, df = 11.9, p = .081), but there was a difference for the younger learners (t = -8.24, df = 13.1, p<.0005).

In R we can see the confidence intervals, which are [-18.81, -0.59] for incidental learning conditions compared to the intentional learning condition for the older learners, but [-39.81, -21.59] for the younger learners. So going by confidence intervals there is an effect for both types of learners but we see that the effect is much greater for the younger learners. Both CIs are about 18 points wide (which seems rather imprecise), but the CI for the younger learners has a lower limit that is much farther away from zero.

**Bibliography**